Defining simple view causes loop

This forum is to report technical problems with Rel.
Post Reply
HughDarwen
Posts:121
Joined:Sat May 24, 2008 4:49 pm
Defining simple view causes loop

Post by HughDarwen » Sun Mar 24, 2013 4:27 pm

When I create a new v1.0.10 database from the attached backup, various things I attempt to do bring about a loop, reflected by endless repetitions of mysterious messages in the DBrowser Monitor window, as shown in the attachment, loop.d. The third attachment, DefBaseRelvars.d, is one of the scripts that causes the loop. Pressing backup also brings it about.

Hugh Darwen
Attachments
DefBaseRelvars.d
This is an example of something that brought about the loop. Pressing the backup button also brought about the loop.
(107Bytes)Downloaded 223 times
loop.d
This is what was saved when I pressed Save in the DBrowser Monitor window.
(89.82KiB)Downloaded 217 times
db-causing-loops.d
This backup was taken back in September 2010, but I've replaced the operator definitions taken from OperatorsChar.d by those provided with v1.0.10.
(16.73KiB)Downloaded 224 times

Dave
Site Admin
Posts:368
Joined:Sun Nov 27, 2005 7:19 pm

Re: Defining simple view causes loop

Post by Dave » Sun Mar 24, 2013 6:20 pm

I'll test this thoroughly, but as a quick answer I suspect the following operator definitions from your backup are at the root of it:

Code: Select all

ANNOUNCE 'operator OP_EQUALS';
OPERATOR OP_EQUALS(P# PNO, PC CHARACTER) RETURNS BOOLEAN; RETURN THE_c ( P# ) = PC ; END OPERATOR ;

ANNOUNCE 'operator OP_EQUALS';
OPERATOR OP_EQUALS(S# SNO, SC CHARACTER) RETURNS BOOLEAN; RETURN THE_c ( S# ) = SC ; END OPERATOR ;
Could you try creating a new database and load a backup with the above two OPERATOR definitions omitted, and let me know if there are any problems?

HughDarwen
Posts:121
Joined:Sat May 24, 2008 4:49 pm

Re: Defining simple view causes loop

Post by HughDarwen » Tue Mar 26, 2013 11:50 am

Yes. I deleted those operator definitions and everything then worked fine.

Hugh

Dave
Site Admin
Posts:368
Joined:Sun Nov 27, 2005 7:19 pm

Re: Defining simple view causes loop

Post by Dave » Wed Mar 27, 2013 2:18 pm

Excellent. It's good to know there's a workaround, and it clearly highlights what I need to work on.

Post Reply